Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> IlohaMail Contacts Deletion Vulnerability


Vulnerability Assessment Details

IlohaMail Contacts Deletion Vulnerability

Vulnerability Assessment Summary
Checks for Contacts Deletion vulnerability in IlohaMail

Detailed Explanation for this Vulnerability Assessment

The target is running at least one instance of IlohaMail version
0.7.9-RC2 or earlier. Such versions contain a flaw that enables an
authenticated user to delete contacts belonging to any user provided
the DB-based backend is used to store contacts. The flaw arises
because ownership of 'delete_item' is not checked when deleting
entries in include/save_contacts.MySQL.inc.

***** Nessus has acertaind the vulnerability exists on the target
***** simply by looking at the version number of IlohaMail
***** installed there.

Solution : Upgrade to IlohaMail version 0.7.9 or later.

Network Security Threat Level: Low

Networks Security ID:

Vulnerability Assessment Copyright: This script is Copyright (C) 2004 George A. Theall

Cables, Connectors

Dell PowerEdge R630 2x E5-2640v3 2.6GHz 8 Core 64GB 8x 300GB 15K SAS PERC H730
$3206.25
Dell PowerEdge R630 2x E5-2640v3 2.6GHz 8 Core 64GB 8x 300GB 15K SAS PERC H730 pictureDell PowerEdge R710 2x X5680 3.33GHz 6 Core 128GB 8x 600GB 10K SAS PERC 6/i
$1854.0
Dell PowerEdge R710 2x X5680 3.33GHz 6 Core 128GB 8x 600GB 10K SAS PERC 6/i pictureDell PowerEdge R720xd 2x E5-2630 v2 2.6GHz 6 Core 96GB 12x 600GB 15K SAS H710P
$2939.3
Dell PowerEdge R720xd 2x E5-2630 v2 2.6GHz 6 Core 96GB 12x 600GB 15K SAS H710P picture


Discussions

No Discussions have been posted on this vulnerability.