Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Gentoo Local Security Checks >> [GLSA-200701-19] OpenLDAP: Insecure usage of /tmp during installation


Vulnerability Assessment Details

[GLSA-200701-19] OpenLDAP: Insecure usage of /tmp during installation

Vulnerability Assessment Summary
OpenLDAP: Insecure usage of /tmp during installation

Detailed Explanation for this Vulnerability Assessment
The remote host is affected by the vulnerability described in GLSA-200701-19
(OpenLDAP: Insecure usage of /tmp during installation)


Tavis Ormandy of the Gentoo Linux Security Team has discovered that the
file gencert.sh distributed with the Gentoo ebuild for OpenLDAP does
not exit upon the existence of a directory in /tmp during installation
permiting for directory traversal.

Impact

A local attacker could create a symbolic link in /tmp and potentially
overwrite arbitrary system files upon a privileged user emerging
OpenLDAP.

Workaround

There is no known workaround at this time.


Solution:
All OpenLDAP users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose "net-nds/openldap"


Network Security Threat Level: Low


Networks Security ID:

Vulnerability Assessment Copyright: (C) 2007 Michel Arboi

Cables, Connectors

HP DL380 G10 16-Core Server 2x Bronze 3106 1.7GHz 96GB-16 8x 6TB SAS E408i LFF
$7870.5
HP DL380 G10 16-Core Server 2x Bronze 3106 1.7GHz 96GB-16 8x 6TB SAS E408i LFF pictureDell R630 24-Core Server 2x E5-2670 v3 2.3GHz 192GB-16 4x 480GB SSD H730 iDRAC
$3709.5
Dell R630 24-Core Server 2x E5-2670 v3 2.3GHz 192GB-16 4x 480GB SSD H730 iDRAC pictureDell R630 24-Core Server 2x E5-2670 v3 2.3GHz 192GB-16 8x 600GB 15K N SAS H730
$5334.0
Dell R630 24-Core Server 2x E5-2670 v3 2.3GHz 192GB-16 8x 600GB 15K N SAS H730 pictureDell R730xd 24C Server 2x E5-2670 v3 2.3GHz 128GB-16 12x 4TB 2x 300GB H730 3.5in
$4839.0
Dell R730xd 24C Server 2x E5-2670 v3 2.3GHz 128GB-16 12x 4TB 2x 300GB H730 3.5in picture


Discussions

No Discussions have been posted on this vulnerability.