Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Fedora Local Security Checks >> Fedora Core 2 2004-402: ruby


Vulnerability Assessment Details

Fedora Core 2 2004-402: ruby

Vulnerability Assessment Summary
Check for the version of the ruby package

Detailed Explanation for this Vulnerability Assessment

The remote host is missing the patch for the advisory FEDORA-2004-402 (ruby).

Ruby is the interpreted scripting language for quick and easy
object-oriented programming. It has many features to process text
files and to do system management tasks (as in Perl). It is simple,
straight-forward, and extensible.


* Thu Nov 11 2004 Akira TAGOH - 1.8.1-6.FC2.0

- security fix [CVE-2004-0983]
- ruby-1.8.1-cgi-dos.patch: applied to fix a denial of service issue.
(#138366)



Solution : http://www.fedoranews.org/blog/index.php?p=62
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is Copyright (C) 2004 Tenable Network Security

Cables, Connectors

Pfsense,centOS,Linux,firewall X86 Fanless 4 RS232 Nano PC,Q190P 1080P 2G/16G
$182.7
Pfsense,centOS,Linux,firewall X86 Fanless 4 RS232 Nano PC,Q190P 1080P 2G/16G pictureSONICWALL 01-SSC-1742 TZ300 Sec Upg Plus AE 2 YR
$1099.47
SONICWALL 01-SSC-1742 TZ300 Sec Upg Plus AE 2 YR picturePersonal Firewall PC(CD-ROM Software) For Windows XP/2000/Me/98/95
$7.99
Personal Firewall PC(CD-ROM Software) For Windows XP/2000/Me/98/95 pictureSonicwall TZ100 TZ 100 Network Security Appliance Firewall w/Adapter
$45.0
Sonicwall TZ100 TZ 100 Network Security Appliance Firewall w/Adapter picture


Discussions

No Discussions have been posted on this vulnerability.