Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Fedora Local Security Checks >> Fedora Core 1 2004-174: libpng10


Vulnerability Assessment Details

Fedora Core 1 2004-174: libpng10

Vulnerability Assessment Summary
Check for the version of the libpng10 package

Detailed Explanation for this Vulnerability Assessment

The remote host is missing the patch for the advisory FEDORA-2004-174 (libpng10).

The libpng10 package contains an old version of libpng, a library of
functions for creating and manipulating PNG (Portable Network Graphics)
image format files.

This package is needed if you want to run binaries that were linked
dynamically
with libpng 1.0.x.

Update Information:

During an audit of Red Hat Linux updates, the Fedora Legacy team found a
security issue in libpng that had not been fixed in Fedora Core. An
attacker could carefully craft a PNG file in such a way that
it would cause an application linked to libpng to crash or potentially
execute arbitrary code when opened by a victim.



Solution : http://www.fedoranews.org/updates/FEDORA-2004-174.shtml
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is Copyright (C) 2004 Tenable Network Security

Cables, Connectors

5 terabyte hardrive
$100.0
5 terabyte hardrive pictureArealer 2.5" SATA III SATA3 128GB 128G SSD Internal Solid State Drive 6Gbps I9X6
$41.42
Arealer 2.5Arealer 256GB SATA III 6Gbps 2.5" inch Solid State Drive SSD for Desktop PC D1N8
$60.41
Arealer 256GB SATA III 6Gbps 2.5320GB Acer Aspire 5810TZG 2.5" SATA Laptop Hard Drive HDD Upgrade Replacement
$50.72
320GB Acer Aspire 5810TZG 2.5


Discussions

No Discussions have been posted on this vulnerability.