Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Debian Local Security Checks >> [DSA969] DSA-969-1 scponly


Vulnerability Assessment Details

[DSA969] DSA-969-1 scponly

Vulnerability Assessment Summary
DSA-969-1 scponly

Detailed Explanation for this Vulnerability Assessment

Max Vozeler discovered a vulnerability in scponly, a utility to
restrict user commands to scp and sftp, that could lead to the
execution of arbitrary commands as root. The system is only vulnerable
if the program scponlyc is installed setuid root and if regular users
have shell access to the machine.
The old stable distribution (woody) does not contain an scponly package.
For the stable distribution (sarge) this problem has been fixed in
version 4.0-1sarge1.
For the unstable distribution (sid) this problem has been fixed in
version 4.6-1.
We recommend that you upgrade your scponly package.


Solution : http://www.debian.org/security/2006/dsa-969
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is (C) 2007 Michel Arboi

Cables, Connectors

JumpDisk - 86 disks lot - Disk Magazine for the Commodore Amiga
$39.31
JumpDisk - 86 disks lot  - Disk Magazine for the Commodore Amiga  pictureAMIGA 600 PAL MODEL VINTAGE CAPACITORS REPLACED FULLY FUNCTIONAL Ships from USA
$650.0
AMIGA 600 PAL MODEL VINTAGE CAPACITORS REPLACED FULLY FUNCTIONAL Ships from USA pictureAmiga CD32 with USA power, new controller and encyclopedia disk.
$349.0
Amiga CD32 with USA power, new controller and encyclopedia disk. pictureAmiga 2000 Microbotics Board 8UP DIP Rev 2.0
$39.99
Amiga 2000 Microbotics Board 8UP DIP Rev 2.0 picture


Discussions

No Discussions have been posted on this vulnerability.