Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Debian Local Security Checks >> [DSA892] DSA-892-1 awstats


Vulnerability Assessment Details

[DSA892] DSA-892-1 awstats

Vulnerability Assessment Summary
DSA-892-1 awstats

Detailed Explanation for this Vulnerability Assessment

Peter Vreugdenhil discovered that awstats, a featureful web server log
analyser, passes user-supplied data to an eval() function, permiting
remote attackers to execute arbitrary Perl commands.
The old stable distribution (woody) is not affected by this problem.
For the stable distribution (sarge) this problem has been fixed in
version 6.4-1sarge1.
For the unstable distribution (sid) this problem has been fixed in
version 6.4-1.1.
We recommend that you upgrade your awstats package.


Solution : http://www.debian.org/security/2005/dsa-892
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is (C) 2007 Michel Arboi

Cables, Connectors

Flash Drive 16GB, Pen Drive Memory Stick USB2.0 AreTop Cute Cartoon Minia... New
$13.99
Flash Drive 16GB, Pen Drive Memory Stick USB2.0 AreTop Cute Cartoon Minia... New pictureLexar JumpDrive TwistTurn 8 GB USB Flash Drive
$12.0
Lexar JumpDrive TwistTurn 8 GB USB Flash Drive picture Verbatim 16GB Store 'n' Go V3 USB 3.0 Flash Drive - 3pk - Blue, Green, Gray, 3
$42.81
 Verbatim 16GB Store 'n' Go V3 USB 3.0 Flash Drive - 3pk - Blue, Green, Gray, 3 picture10Lot 1GB USB 2.0 Flash Drive Memory Stick Storage Thumb Pen Drives Flash Disk
$31.99
10Lot 1GB USB 2.0 Flash Drive Memory Stick Storage Thumb Pen Drives Flash Disk  picture


Discussions

No Discussions have been posted on this vulnerability.