Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Debian Local Security Checks >> [DSA863] DSA-863-1 xine-lib


Vulnerability Assessment Details

[DSA863] DSA-863-1 xine-lib

Vulnerability Assessment Summary
DSA-863-1 xine-lib

Detailed Explanation for this Vulnerability Assessment

Ulf Härnhammar from the Debian Security Audit Project discovered a
format string vulnerability in the CDDB processing component of
xine-lib, the xine video/media player library, that could lead to the
execution of arbitrary code caused by a malicious CDDB entry.
For the old stable distribution (woody) this problem has been fixed in
version 0.9.8-2woody4.
For the stable distribution (sarge) this problem has been fixed in
version 1.0.1-1sarge1.
For the unstable distribution (sid) this problem will be fixed soon.
We recommend that you upgrade your libxine0 and libxine1 packages.


Solution : http://www.debian.org/security/2005/dsa-863
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is (C) 2005 Michel Arboi

Cables, Connectors

Cisco Catalyst WS-C3750-48PS-S 48 Port PoE Switch
$51.99
Cisco Catalyst WS-C3750-48PS-S 48 Port PoE Switch picture2 NETGEAR GS605 5-Port Gigabit Desktop Switch - switch - 5 ports 10/100/1000 lot
$7.4
2 NETGEAR GS605 5-Port Gigabit Desktop Switch - switch - 5 ports 10/100/1000 lot pictureRosewill CS682 - KVM / audio / USB switch - 2 ports
$9.99
Rosewill CS682 - KVM / audio / USB switch - 2 ports pictureRobec MR2-25, 2 position parallel switch box
$10.0
Robec MR2-25, 2 position parallel switch box picture


Discussions

No Discussions have been posted on this vulnerability.