Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Debian Local Security Checks >> [DSA817] DSA-817-1 python2.2


Vulnerability Assessment Details

[DSA817] DSA-817-1 python2.2

Vulnerability Assessment Summary
DSA-817-1 python2.2

Detailed Explanation for this Vulnerability Assessment

An integer overflow with a subsequent buffer overflow has been detected
in PCRE, the Perl Compatible Regular Expressions library, which permits
a possible hacker to execute arbitrary code, and is also present in Python.
Exploiting this vulnerability requires a possible hacker to specify the used
regular expression.
For the old stable distribution (woody) this problem has been fixed in
version 2.2.1-4.8.
For the stable distribution (sarge) this problem has been fixed in
version 2.2.3dfsg-2sarge1.
For the unstable distribution (sid) this problem has been fixed in
version 2.2.3dfsg-4.
We recommend that you upgrade your python2.2 packages.


Solution : http://www.debian.org/security/2005/dsa-817
Network Security Threat Level: High

Networks Security ID: 14620

Vulnerability Assessment Copyright: This script is (C) 2007 Michel Arboi

Cables, Connectors

LENOVO THINKSERVER RD550 E5-2640V3 2.6GHZ 96GB 3 X 1.2TB 10K SAS
$3639.0
LENOVO THINKSERVER RD550 E5-2640V3 2.6GHZ 96GB 3 X 1.2TB 10K SAS pictureLenovo IdeaPad V110-15ISK - 15.6", i3 NO RAM NO HD Parts 4
$79.0
Lenovo IdeaPad V110-15ISK - 15.6Car Charger 90W 65W 45W For Lenovo Thinkpad Edge Carbon Yoga Flex...
$29.47
Car Charger 90W 65W 45W For Lenovo Thinkpad Edge Carbon Yoga Flex...  picture


Discussions

No Discussions have been posted on this vulnerability.