Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Debian Local Security Checks >> [DSA753] DSA-753-1 gedit


Vulnerability Assessment Details

[DSA753] DSA-753-1 gedit

Vulnerability Assessment Summary
DSA-753-1 gedit

Detailed Explanation for this Vulnerability Assessment

A format string vulnerability has been discovered in gedit, a
light-weight text editor for GNOME, that may permit attackers to cause
a denial of service (application crash) via a binary file with format
string specifiers in the filename. Since gedit supports opening files
via "http://" URLs (through GNOME vfs) and other schemes, this might
be a remotely exploitable vulnerability.
The old stable distribution (woody) is not vulnerable to this problem.
For the stable distribution (sarge) this problem has been fixed in
version 2.8.3-4sarge1.
For the unstable distribution (sid) this problem has been fixed in
version 2.10.3-1.
We recommend that you upgrade your gedit package.


Solution : http://www.debian.org/security/2005/dsa-753
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is (C) 2007 Michel Arboi

Cables, Connectors

WatchGuard XTM21 Firewall (XP3E6)
$30.0
WatchGuard XTM21 Firewall (XP3E6) pictureWatchGuard XTM21-W Firewall (XP3E6W)
$40.0
WatchGuard XTM21-W Firewall (XP3E6W) pictureCisco ASA 5510 A06 Adaptive Security Appliance
$25.0
Cisco ASA 5510 A06 Adaptive Security Appliance pictureLot of 2 - Sonicwall Internet Security Firewalls - APL14-034 and APL11-029
$17.99
Lot of 2 - Sonicwall Internet Security Firewalls - APL14-034 and APL11-029 picture


Discussions

No Discussions have been posted on this vulnerability.