Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Debian Local Security Checks >> [DSA537] DSA-537-1 ruby


Vulnerability Assessment Details

[DSA537] DSA-537-1 ruby

Vulnerability Assessment Summary
DSA-537-1 ruby

Detailed Explanation for this Vulnerability Assessment

Andres Salomon noticed a problem in the CGI session management of
Ruby, an object-oriented scripting language. CGI::Session's FileStore
(and presumably PStore, but not in Debian woody) implementations store
session information insecurely. They simply create files, ignoring
permission issues. This can lead a possible hacker who has also shell
access to the webserver to take over a session.
For the stable distribution (woody) this problem has been fixed in
version 1.6.7-3woody3.
For the unstable and testing distributions (sid and sarge) this
problem has been fixed in version 1.8.1+1.8.2pre1-4.
We recommend that you upgrade your libruby package.


Solution : http://www.debian.org/security/2004/dsa-537
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is (C) 2005 Michel Arboi

Cables, Connectors

Dell PowerEdge R610 2x X5550 2.66GHz Quad Core 16GB 6x 512GB SATA SSD PERC 6/i
$1340.0
Dell PowerEdge R610 2x X5550 2.66GHz Quad Core 16GB 6x 512GB SATA SSD PERC 6/i pictureDell PowerEdge R610 2x X5670 2.93GHz 6 Core 64GB 6x 512GB SATA SSD PERC 6/i
$1650.0
Dell PowerEdge R610 2x X5670 2.93GHz 6 Core 64GB 6x 512GB SATA SSD PERC 6/i picture2006 Mac Pro Desktop 4-Core Intel Xeon 2.66Ghz
$75.0
2006 Mac Pro Desktop 4-Core Intel Xeon 2.66Ghz  picture*Lot of 10* Intel Xeon E5620@2.4GHz 12M 5.86 SLBV4 Processor
$39.95
*Lot of 10* Intel Xeon E5620@2.4GHz 12M 5.86 SLBV4 Processor picture


Discussions

No Discussions have been posted on this vulnerability.