Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Debian Local Security Checks >> [DSA190] DSA-190-1 wmaker


Vulnerability Assessment Details

[DSA190] DSA-190-1 wmaker

Vulnerability Assessment Summary
DSA-190-1 wmaker

Detailed Explanation for this Vulnerability Assessment

Al Viro found a problem in the image handling code use in Window Maker,
a popular NEXTSTEP like window manager. When creating an image it would
allocate a buffer by multiplying the image width and height, but did not
check for an overflow. This makes it possible to overflow the buffer.
This could be exploited by using specially crafted image files (for
example when previewing themes).
This problem has been fixed in version 0.80.0-4.1 for the current stable
distribution (woody). Packages for the mipsel architecture are not yet
available.


Solution : http://www.debian.org/security/2002/dsa-190
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is (C) 2005 Michel Arboi

Cables, Connectors

Brand New Alcatel-Lucent OS6450-XNI-U2 10 Gigabit SFP+ Stacking Module
$325.0
Brand New Alcatel-Lucent OS6450-XNI-U2 10 Gigabit SFP+ Stacking Module pictureCisco SG500X-48 V02 48GE 4 10GE SFP+
$700.0
Cisco SG500X-48 V02 48GE 4 10GE SFP+ pictureCisco QSFP-4SFP10G-CU3M 40GB QSFP to 4X 10GB SFP+ Breakout Cable
$199.99
Cisco QSFP-4SFP10G-CU3M 40GB QSFP to 4X 10GB SFP+ Breakout Cable  picture* LOT OF 6 * FTLF8528P2BNV-EM - Finisar 8Gb/s 850nm 150m SFP+ GBICs/Transceivers
$45.0
* LOT OF 6 * FTLF8528P2BNV-EM - Finisar 8Gb/s 850nm 150m SFP+ GBICs/Transceivers picture


Discussions

No Discussions have been posted on this vulnerability.