Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Debian Local Security Checks >> [DSA1139] DSA-1139-1 ruby1.6


Vulnerability Assessment Details

[DSA1139] DSA-1139-1 ruby1.6

Vulnerability Assessment Summary
DSA-1139-1 ruby1.6

Detailed Explanation for this Vulnerability Assessment

It was discovered that the interpreter for the Ruby language does not
properly maintain "safe levels" for aliasing, directory accesses and
regular expressions, which might lead to a bypass of security
restrictions.
For the stable distribution (sarge) this problem has been fixed in
version 1.6.8-12sarge2.
The unstable distribution (sid) does no longer contain ruby1.6 packages.
We recommend that you upgrade your Ruby packages.


Solution : http://www.debian.org/security/2006/dsa-1139
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is (C) 2006 Michel Arboi

Cables, Connectors

Magic Workbench Enhancer v2 - Amiga CD
$3.91
Magic Workbench Enhancer v2 - Amiga CD pictureSPARE PARTS FOR CLASSIC AMIGA ORIGINAL SQUARE 5PIN DIN POWER SUPPLY CONNECTOR
$5.5
SPARE PARTS FOR CLASSIC AMIGA ORIGINAL SQUARE 5PIN DIN POWER SUPPLY CONNECTOR  pictureAmiga Computer Game - Quake
$50.0
Amiga Computer Game - Quake pictureAmiga 4000 keyboard converter
$12.0
Amiga 4000 keyboard converter picture


Discussions

No Discussions have been posted on this vulnerability.