Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Debian Local Security Checks >> [DSA1121] DSA-1121-1 postgrey


Vulnerability Assessment Details

[DSA1121] DSA-1121-1 postgrey

Vulnerability Assessment Summary
DSA-1121-1 postgrey

Detailed Explanation for this Vulnerability Assessment

Peter Bieringer discovered that postgrey, a greylisting
implementation for Postfix, is vulnerable to a format string attack
that permits remote attackers to cause a denial of service to the daemon.
For the stable distribution (sarge) this problem has been fixed in
version 1.21-1sarge1.
For the stable distribution (sarge) this problem has also been fixed
in version 1.21-1volatile4 in the volatile archive.
For the unstable distribution (sid) this problem has been fixed in
version 1.22-1.
We recommend that you upgrade your postgrey package.


Solution : http://www.debian.org/security/2006/dsa-1121
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is (C) 2007 Michel Arboi

Cables, Connectors

AMD Ryzen 7 1700 3.7GHz Eight Core Processor AM4 CPU
$153.24
AMD Ryzen 7 1700 3.7GHz Eight Core Processor AM4 CPU pictureIntel Core i5-6500 Quad-Core (BX80662I56500) Processor
$150.0
Intel Core i5-6500 Quad-Core (BX80662I56500) Processor pictureMacbook Pro A1278 CPU Cooling Fan Laptop Replacement Parts
$8.99
Macbook Pro A1278 CPU Cooling Fan Laptop Replacement Parts pictureAMD Athlon II X4 645 ADX645WFK42GM 3.1 GHz quad core socket AM3 CPU Propus 95W
$26.95
AMD Athlon II X4 645 ADX645WFK42GM 3.1 GHz quad core socket AM3 CPU Propus 95W picture


Discussions

No Discussions have been posted on this vulnerability.