Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Debian Local Security Checks >> [DSA1026] DSA-1026-1 sash


Vulnerability Assessment Details

[DSA1026] DSA-1026-1 sash

Vulnerability Assessment Summary
DSA-1026-1 sash

Detailed Explanation for this Vulnerability Assessment

Markus Oberhumer discovered a flaw in the way zlib, a library used for
file compression and decompression, handles invalid input. This flaw can
cause programs which use zlib to crash when opening an invalid file.
A further error in the way zlib handles the inflation of certain
compressed files can cause a program which uses zlib to crash when opening
an invalid file.
sash, the stand-alone shell, links statically against zlib, and was
thus affected by these problems.
The old stable distribution (woody) isn't affected by these problems.
For the stable distribution (sarge) these problems have been fixed in
version 3.7-5sarge1.
For the unstable distribution (sid) these problems have been fixed in
version 3.7-6.
We recommend that you upgrade your sash package.


Solution : http://www.debian.org/security/2006/dsa-1026
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is (C) 2007 Michel Arboi

Cables, Connectors

D-Link DIR-615 300Mbps High Speed 802.11n Wireless 4 Ports Router With Firewall
$19.99
 D-Link DIR-615 300Mbps High Speed 802.11n Wireless 4 Ports Router With Firewall pictureNokia firewall hard disk carrier card N805751001 A
$36.0
Nokia firewall hard disk carrier card N805751001 A pictureJuniper SSG-5-SB Security Gateway 6 Port Firewall
$24.99
Juniper SSG-5-SB Security Gateway 6 Port Firewall pictureCheck Point 730 Appliance Next Generation Threat Prevention
$200.0
Check Point 730 Appliance Next Generation Threat Prevention picture


Discussions

No Discussions have been posted on this vulnerability.