Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> Blazix Web Server JSP source disclosure


Vulnerability Assessment Details

Blazix Web Server JSP source disclosure

Vulnerability Assessment Summary
Attempts to read the source of a jsp page

Detailed Explanation for this Vulnerability Assessment

It is possible to make the remote web server disclose the source
code of its JSP pages by requesting the pages while appending a plus
sign or a backslash to its name (ie: filename.jsp+ instead of filename.jsp).

A possible hacker may use this flaw to get the source code of your CGIs
and possibly obtain passwords and other relevant information about
this host.

Solution : Upgrade to Blazix 1.2.1 or newer
Network Security Threat Level: High

Networks Security ID: 5566, 5567

Vulnerability Assessment Copyright: This script is Copyright (C) 2005 Tenable Network Security

Cables, Connectors

Dell PowerEdge R620 2x E5-2690v2 3.0GHz 10 Core 16GB 8x 900GB 10K SAS PERC H710
$6050.0
Dell PowerEdge R620 2x E5-2690v2 3.0GHz 10 Core 16GB 8x 900GB 10K SAS PERC H710 pictureDell PowerEdge R610 2x X5660 2.8GHz 6 Core 64GB 6x 146GB 15K SAS PERC 6/i
$865.0
Dell PowerEdge R610 2x X5660 2.8GHz 6 Core 64GB 6x 146GB 15K SAS PERC 6/i pictureDell PowerEdge R620 2x E5-2650 v2 2.6GHz 8 Core 48GB 8x 300GB 10K SAS PERC H710
$2210.0
Dell PowerEdge R620 2x E5-2650 v2 2.6GHz 8 Core 48GB 8x 300GB 10K SAS PERC H710 pictureDell PowerEdge R620 2x E5-2620 2.0GHz 6 Core 16GB 8x 300GB 15K SAS PERC H710
$1520.0
Dell PowerEdge R620 2x E5-2620 2.0GHz 6 Core 16GB 8x 300GB 15K SAS PERC H710 picture


Discussions

No Discussions have been posted on this vulnerability.