Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Web Servers >> Apache <= 1.3.33 htpasswd local overflow


Vulnerability Assessment Details

Apache <= 1.3.33 htpasswd local overflow

Vulnerability Assessment Summary
Checks for Apache <= 1.3.33

Detailed Explanation for this Vulnerability Assessment

The remote host appears to be running Apache 1.3.33 or older.

There is a local buffer overflow in the 'htpasswd' command in these
versions that may permit a local user to gain elevated rights if
'htpasswd' is run setuid or a remote user to run arbitrary commands
remotely if the script is accessible through a CGI.

*** Note that Nessus solely relied on the version number
*** of the remote server to issue this warning. This might
*** be a false positive

See also : http://archives.neohapsis.com/archives/bugtraq/2004-10/0345.html
Solution : Make sure htpasswd does not run setuid and is not accessible
through any CGI scripts.
Network Security Threat Level: Medium

Networks Security ID: 13777, 13778

Vulnerability Assessment Copyright: This script is Copyright (C) 2004 David Maciejak

Cables, Connectors

Flexible Desktop Phone Tablet Stand Holder For iPad Mini Air Samsung For Ipho...
$31.99
Flexible Desktop Phone Tablet Stand Holder For iPad Mini Air Samsung For Ipho... pictureSAMSUNG NP-RV515 CABLE FLEX BA39-01030A ORIGINAL/TESTED
$23.35
SAMSUNG NP-RV515 CABLE FLEX BA39-01030A ORIGINAL/TESTED pictureBlack Flexible Stand Holder Lazy Bracket Phone Car Bed Desk For iPhone Samsung
$11.24
Black Flexible Stand Holder Lazy Bracket Phone Car Bed Desk For iPhone Samsung picture


Discussions

No Discussions have been posted on this vulnerability.