Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> FTP >> bftpd chown overflow


Vulnerability Assessment Details

bftpd chown overflow

Vulnerability Assessment Summary
Checks if the remote bftpd daemon is vulnerable to a buffer overflow

Detailed Explanation for this Vulnerability Assessment

The remote ftp server is vulnerable to a buffer overflow
when issued too long arguments to the chown command.

It may be possible for a remote attacker to gain root access
thanks to this bug.

Solution : Upgrade your bftpd server to version 1.0.14 or
disable the option ENABLE_SITE in bftpd.conf
Network Security Threat Level: High

Networks Security ID: 2120

Vulnerability Assessment Copyright: This script is Copyright (C) Tenable Network Security

Cables, Connectors

IBM 47C8665 IBM ServeRAID M5200 Series 2GB flash (RAID 5 Upgrade)
$375.8
IBM 47C8665 IBM ServeRAID M5200 Series 2GB flash (RAID 5 Upgrade) pictureLenovo 00KA977 Lenovo 2.5-inch HDD 2x right angle + cable, (NO RAID) - NeXtScale
$62.0
Lenovo 00KA977 Lenovo 2.5-inch HDD 2x right angle + cable, (NO RAID) - NeXtScale pictureLenovo 03T8593 Lenovo ThinkServer RD450 RAID 510i AnyRAID Adapter
$129.0
Lenovo 03T8593 Lenovo ThinkServer RD450 RAID 510i AnyRAID Adapter pictureLenovo 00KG132 Lenovo nx360 RAID Adapter Riser
$168.5
Lenovo 00KG132 Lenovo nx360 RAID Adapter Riser picture


Discussions

No Discussions have been posted on this vulnerability.