Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> FTP >> wu-ftpd fb_realpath() off-by-one overflow


Vulnerability Assessment Details

wu-ftpd fb_realpath() off-by-one overflow

Vulnerability Assessment Summary
Checks the banner of the remote wu-ftpd server

Detailed Explanation for this Vulnerability Assessment

The remote Wu-FTPd server seems to be vulnerable to an off-by-one
overflow when dealing with huge directory structures.

A possible hacker may exploit this flaw to obtain a shell on this host.

*** Nessus solely relied on the banner of the remote server
*** to issue this warning, so it may be a false positive.
*** Since Wu-FTPd 2.6.3 has not been released yet and only
*** patches are available to fix this issue, this might be
*** a false positive.

Solution : Upgrade to Wu-FTPd 2.6.3 when available or apply the
patches available at http://www.wu-ftpd.org

Network Security Threat Level: High

Networks Security ID: 8315

Vulnerability Assessment Copyright: This script is Copyright (C) 2003-2007 Tenable Network Security

Cables, Connectors

Juniper PE-4DS3-ATM2, 4 Port DS3 ATM2 IQ PIC, Expansion Module for M7i Router
$229.99
Juniper PE-4DS3-ATM2, 4 Port DS3 ATM2 IQ PIC, Expansion Module for M7i Router pictureT640 Juniper 740-002595 Cherokee DC Power Supply PWR-T-DC-S-B Entry Module
$35.99
T640 Juniper 740-002595 Cherokee DC Power Supply PWR-T-DC-S-B Entry Module pictureJUNIPER Channelized 4 Port DS-3 Physical Interface Card PIC Module P-4CHDS3
$87.99
JUNIPER Channelized 4 Port DS-3 Physical Interface Card PIC Module P-4CHDS3 pictureNew Juniper SRX3400BASE-AC SRX 3400
$1200.0
New Juniper SRX3400BASE-AC  SRX 3400 picture


Discussions

No Discussions have been posted on this vulnerability.