Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> FTP >> wu-ftpd MAIL_ADMIN overflow


Vulnerability Assessment Details

wu-ftpd MAIL_ADMIN overflow

Vulnerability Assessment Summary
Checks the banner of the remote wu-ftpd server

Detailed Explanation for this Vulnerability Assessment

The remote Wu-FTPd server seems to be vulnerable to a remote flaw.

This version fails to properly check bounds on a pathname when Wu-Ftpd is
compiled with MAIL_ADMIN enabled resulting in a buffer overflow. With a
specially crafted request, a possible hacker can possibly execute arbitrary code
as the user Wu-Ftpd runs as (usually root) resulting in a loss of integrity,
and/or availability.

It should be noted that this vulnerability is not present within the default
installation of Wu-Ftpd.

The server must be configured using the 'MAIL_ADMIN' option to notify an
administrator when a file has been uploaded.

*** Nessus solely relied on the banner of the remote server
*** to issue this warning, so it may be a false positive.

Solution : Upgrade to Wu-FTPd 2.6.3 when available
Network Security Threat Level: High

Networks Security ID: 8668

Vulnerability Assessment Copyright: This script is Copyright (C) 2004 David Maciejak

Cables, Connectors

Vintage Atari Model 410 Program Recorder
$17.96
Vintage Atari Model 410 Program Recorder pictureAtari XL XE 600XL 800XL 800XE 65XE 130XE XEGS Compact Power Supply Fully Tested
$13.34
Atari XL XE 600XL 800XL 800XE 65XE 130XE XEGS Compact Power Supply Fully Tested pictureKen Uston's Professional Blackjack Commodore 64 and Atari - C64 Tested
$10.0
Ken Uston's Professional Blackjack Commodore 64 and Atari - C64 Tested pictureVintage Apple Atari IBM PC Com 64 & Vic-20 Software Catalog Broderbund Sotware
$29.99
Vintage Apple Atari IBM PC Com 64 & Vic-20 Software Catalog Broderbund Sotware picture


Discussions

No Discussions have been posted on this vulnerability.