Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Gain root remotely >> rsync array overflow


Vulnerability Assessment Details

rsync array overflow

Vulnerability Assessment Summary
Acertains if the remote rsync is buggy

Detailed Explanation for this Vulnerability Assessment

The remote rsync server is vulnerable to an array index
overflow.

A possible hacker may use this flaw to gain a shell on this host

Solution : Upgrade to rsync 2.5.2 or newer
Network Security Threat Level: High

Networks Security ID: 3958

Vulnerability Assessment Copyright: This script is Copyright (C) 2003 Renaud Deraison

Cables, Connectors

Cisco SPA112 2-Port VoIP Phone Adapter
$24.0
Cisco SPA112 2-Port VoIP Phone Adapter pictureCisco Systems Linksys VoIP phone lines Module 2 SPA2102-R2
$29.8
Cisco Systems Linksys VoIP phone lines Module 2 SPA2102-R2 pictureNet Talk Duo connects pc to voip circuit for free national calls $29/year 1 year
$9.0
Net Talk Duo connects pc to voip circuit for free national calls $29/year 1 year pictureObi100 VOIP Telephone Adapter for Google Voice & More
$4.99
Obi100 VOIP Telephone Adapter for Google Voice & More picture


Discussions

No Discussions have been posted on this vulnerability.