Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> phpBannerExchange Template Class Local File Include Vulnerability


Vulnerability Assessment Details

phpBannerExchange Template Class Local File Include Vulnerability

Vulnerability Assessment Summary
Tries to read a file using phpBannerExchange's template class

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote web server contains a PHP script that is prone to a local
file include flaw.

Description :

The remote host is running phpBannerExchange, a banner exchange script
written in PHP.

The version of phpBannerExchange installed on the remote host uses a
template class that fails to sanitize user-supplied input before using
it in a PHP 'include()' function. An unauthenticated attacker can
exploit this issue to view arbitrary files and possibly to execute
arbitrary PHP code on the affected system subject to the rights of
the web server user id.

See also :

http://lists.grok.org.uk/pipermail/full-disclosure/2006-March/042769.html

Solution :

Unknown at this time.

Network Security Threat Level:

Low / CVSS Base Score : 2.3
(AV:R/AC:L/Au:NR/C:P/I:N/A:N/B:N)

Networks Security ID: 16996

Vulnerability Assessment Copyright: This script is Copyright (C) 2006 Tenable Network Security

Cables, Connectors

DELL POWEREDGE M630 E5-2690V4 2.6GHZ 16GB 2133MHZ 2 X 1TB SATA S130
$2979.0
DELL POWEREDGE M630 E5-2690V4 2.6GHZ 16GB 2133MHZ 2 X 1TB SATA S130 pictureDELL POWEREDGE M520 TWO E5-2450L 1.80GHZ 128GB 2 X 250GB SATA
$1839.0
DELL POWEREDGE M520 TWO E5-2450L 1.80GHZ 128GB 2 X 250GB SATA pictureDELL POWEREDGE M620 BLADE TWO E5-2620V2 2.10GHZ 8GB 1.8TB 10K SAS H310
$1199.0
DELL POWEREDGE M620 BLADE TWO E5-2620V2 2.10GHZ 8GB 1.8TB 10K SAS H310 picture


Discussions

No Discussions have been posted on this vulnerability.