Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> phpBB Module phpbb_root_path Parameter Remote File Include Vulnerability


Vulnerability Assessment Details

phpBB Module phpbb_root_path Parameter Remote File Include Vulnerability

Vulnerability Assessment Summary
Tries to read a local file using phpBB modules

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote web server contains a PHP application that is prone to
remote file include attacks.

Description :

The remote host contains a third-party module for phpBB.

The version of at least one such component or module installed on the
remote host fails to sanitize input to the 'phpbb_root_path' parameter
before using it to include PHP code. Provided PHP's
'register_globals' setting is enabled, an unauthenticated attacker may
be able to exploit these flaws to view arbitrary files on the remote
host or to execute arbitrary PHP code, possibly taken from third-party
hosts.

See also :

http://pridels.blogspot.com/2006/05/phpbb-auction-mod-remote-file.html
http://milw0rm.com/exploits/2483
http://milw0rm.com/exploits/2522
http://milw0rm.com/exploits/2525
http://milw0rm.com/exploits/2533
http://milw0rm.com/exploits/2538
http://archives.neohapsis.com/archives/bugtraq/2006-10/0210.html
http://www.phpbb.com/phpBB/viewtopic.php?p=2504370&highlight=#2504370
http://www.securityfocus.com/archive/1/452012/30/0/threaded

Solution :

Disable PHP's 'register_globals' setting or contact the product's
author to see if an upgrade exists.

Network Security Threat Level:

High / CVSS Base Score : 7.0
(AV:R/AC:L/Au:NR/C:P/I:P/A:P/B:N)

Networks Security ID: 17822, 20484, 20485, 20493, 20501, 20518, 20525, 20558, 20571, 21171

Vulnerability Assessment Copyright: This script is Copyright (C) 2006-2007 Tenable Network Security

Cables, Connectors

vintage Dec/Digital PDP11 G231 Memory Driver
$370.95
vintage Dec/Digital PDP11 G231 Memory Driver picturevintage Dec/Digital W103 PDP8 Device Selector Flip Chip
$15.99
vintage Dec/Digital W103 PDP8 Device Selector Flip Chip pictureOne Hard Drive Vintage SCSI DEC Digital RF30-EA Two Available J282
$49.5
One Hard Drive Vintage SCSI DEC Digital RF30-EA     Two Available     J282 pictureLot Vintage Connectors DEC 12-22196-01 ESI-7000TX HDI SCSI Dock plus ...
$11.11
Lot Vintage  Connectors  DEC 12-22196-01  ESI-7000TX  HDI SCSI Dock plus ...  picture


Discussions

No Discussions have been posted on this vulnerability.