Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> phpBB Component phpbb_root_path Parameter Remote File Include Vulnerabilities


Vulnerability Assessment Details

phpBB Component phpbb_root_path Parameter Remote File Include Vulnerabilities

Vulnerability Assessment Summary
Tries to read a local file using the phpBB Component

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote web server contains a PHP application that is prone to
remote file include attacks.

Description :

The remote host is running the phpBB component for Mambo, a web-based
bulletin board.

The version of the phpBB component for Mambo installed on the remote
host fails to sanitize input to the 'phpbb_root_path' parameter of the
'download.php' and other scripts before using it to include PHP code.
Provided PHP's 'register_globals' setting is enabled, an
unauthenticated attacker may be able to exploit these flaws to view
arbitrary files on the remote host or to execute arbitrary PHP code,
possibly taken from third-party hosts.

See also :

http://www.milw0rm.com/exploits/1995

Solution :

Unknown at this time.

Network Security Threat Level:

Medium / CVSS Base Score : 6
(AV:R/AC:H/Au:NR/C:P/A:P/I:P/B:N)

Networks Security ID: 18914

Vulnerability Assessment Copyright: This script is Copyright (C) 2006 Tenable Network Security

Cables, Connectors

Dell PowerEdge T610 Tower Server 1x xeon x5687 3.60 ghz-32GB- 4x 1 TB HDD - Z-1
$799.99
Dell PowerEdge T610 Tower Server 1x xeon x5687 3.60 ghz-32GB- 4x 1 TB HDD - Z-1 pictureDell PowerEdge R720xd 2x E5-2640 v2 2.0GHz 8 Core 48GB 12x 1TB 7.2K SATA H710P
$3565.0
Dell PowerEdge R720xd 2x E5-2640 v2 2.0GHz 8 Core 48GB 12x 1TB 7.2K SATA H710P pictureDell PowerEdge R720xd 2x E5-2620 2.0GHz 6 Core 96GB 12x 300GB 15K SAS H710P
$2775.0
Dell PowerEdge R720xd 2x E5-2620 2.0GHz 6 Core 96GB 12x 300GB 15K SAS H710P pictureDell PowerEdge R610 2x X5550 2.66GHz Quad Core 64GB 6x 600GB 10K SAS PERC H700
$1445.0
Dell PowerEdge R610 2x X5550 2.66GHz Quad Core 64GB 6x 600GB 10K SAS PERC H700 picture


Discussions

No Discussions have been posted on this vulnerability.