Vulnerability Assessment & Network Security Forums

If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.

Home >> Browse Vulnerability Assessment Database >> CGI abuses >> phpBB <= 2.0.17 Multiple Vulnerabilities

Vulnerability Assessment Details

phpBB <= 2.0.17 Multiple Vulnerabilities

Vulnerability Assessment Summary
Checks for multiple vulnerabilities in phpBB <= 2.0.17

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote web server contains a PHP application that is affected by
multiple vulnerabilities.

Description :

The remote host is running a version of phpBB that, if using PHP 5
with 'register_globals' enabled, fails to properly deregister global
variables as well as to initialize several variables in various
scripts. A possible hacker may be able to exploit these issues to execute
arbitrary code or to conduct SQL injection and cross-site scripting

See also :

Solution :

Upgrade to phpBB version 2.0.18 or later.

Network Security Threat Level:

High / CVSS Base Score : 7.0

Networks Security ID: 15243, 15246

Vulnerability Assessment Copyright: This script is Copyright (C) 2005-2006 Tenable Network Security

Cables, Connectors


No Discussions have been posted on this vulnerability.