Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> phpBB <= 2.0.15 Remote Code Execution Vulnerability


Vulnerability Assessment Details

phpBB <= 2.0.15 Remote Code Execution Vulnerability

Vulnerability Assessment Summary
Checks for remote code execution vulnerability in phpBB <= 2.0.15

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote web server contains a PHP script that is affected by a code
injection vulnerability.

Description :

The remote host is running a version of phpBB that permits attackers to
inject arbitrary PHP code to the 'viewtopic.php' script to be executed
within the context of the web server userid.

See also :

http://www.securityfocus.com/archive/1/403631/30/0/threaded

Solution :

Upgrade to phpBB version 2.0.16 or later.

Network Security Threat Level:

High / CVSS Base Score : 7
(AV:R/AC:L/Au:NR/C:P/A:P/I:P/B:N)

Networks Security ID: 14086

Vulnerability Assessment Copyright: This script is Copyright (C) 2005-2006 Tenable Network Security

Cables, Connectors

NetGear ProSAFE 5-Port Gigabit Switch GS105v5
$7.5
NetGear ProSAFE 5-Port Gigabit Switch GS105v5 pictureJuniper Networks EX2200-48P-4G REV:A 48 Port PoE Gigabit Switch with rack ears
$90.0
Juniper Networks EX2200-48P-4G REV:A 48 Port PoE Gigabit Switch with rack ears pictureHp Procurve 3500-48-PoE Switch 48 x 10/100 Ports Poe / 4x SFP Slot - J9473A
$152.17
Hp Procurve 3500-48-PoE Switch 48 x 10/100 Ports Poe / 4x SFP Slot - J9473A pictureHP ProCurve Switch 1700-24 - switch - 22 ports
$10.0
HP ProCurve Switch 1700-24 - switch - 22 ports picture


Discussions

No Discussions have been posted on this vulnerability.