Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> phpAdsNew / phpPgAds < 2.0.6 Multiple Vulnerabilities


Vulnerability Assessment Details

phpAdsNew / phpPgAds < 2.0.6 Multiple Vulnerabilities

Vulnerability Assessment Summary
Checks for multiple vulnerabilities in phpAdsNew / phpPgAds < 2.0.6

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote web server contains a PHP application that is affected by
multiple vulnerabilities.

Description :

The remote host is running phpAdsNew / phpPgAds, an open-source banner
ad server.

The version of phpAdsNews / phpPgAds installed on the remote host
suffers from several flaws :

- Remote PHP Code Injection Vulnerability
The XML-RPC library bundled with the application permits
a possible hacker to inject arbitrary PHP code via the
'adxmlrpc.php' script to be executed within the context
of the affected web server user id.

- Multiple Local File Include Vulnerabilities
The application fails to sanitize user-supplied input to
the 'layerstyle' parameter of the 'adlayer.php' script and
the 'language' parameter of the 'admin/js-form.php' script
before using them to include PHP files for execution. An
attacker can exploit these issues to read arbitrary local
files provided PHP's 'magic_quotes' directive is disabled.

- SQL Injection Vulnerability
A possible hacker can manipulate SQL queries via input to the
'clientid' parameter of the 'libraries/lib-view-direct.inc.php'
script.

See also :

http://www.hardened-php.net/advisory_152005.67.html
http://www.securityfocus.com/archive/1/408423/30/120/threaded

Solution :

Upgrade to phpAdsNew / phpPgAds 2.0.6 or later.

Network Security Threat Level:

High / CVSS Base Score : 7
(AV:R/AC:L/Au:NR/C:P/A:P/I:P/B:N)

Networks Security ID: 14560, 14583, 14588, 14584, 14591

Vulnerability Assessment Copyright: This script is Copyright (C) 2005-2006 Tenable Network Security

Cables, Connectors

Atari Arcade Hits CD-ROM
$3.95
Atari Arcade Hits CD-ROM pictureRare Vintage Suncom Tac 5 Suncom Joystick Controller For Atari, Commodore
$30.0
Rare Vintage Suncom Tac 5 Suncom Joystick Controller For Atari, Commodore pictureShamus for Atari 400 800 XL XE
$25.0
Shamus for Atari 400 800 XL XE pictureHardball Atari XL XE with manual
$20.0
Hardball Atari XL XE with manual picture


Discussions

No Discussions have been posted on this vulnerability.