Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> php4 multiple flaws


Vulnerability Assessment Details

php4 multiple flaws

Vulnerability Assessment Summary
Checks for version of PHP

Detailed Explanation for this Vulnerability Assessment

The remote host is running a version of PHP which is
older than 4.3.3.

All version of PHP 4 older than 4.3.3 are vulnerable to multiple integer
overflow vulnerabilities which might permit a possible hacker to execute arbitrary
commands on this host. Another problem may also invalidate safe_mode.

See also : http://www.php.net/ChangeLog-4.php
Solution : Upgrade to PHP 4.3.3
Network Security Threat Level: Medium

Networks Security ID: 6488, 7761, 8693, 8696

Vulnerability Assessment Copyright: This script is Copyright (C) 2003 Tenable Network Security

Cables, Connectors

SUN ORACLE X3-2L / X4270 M3 2X 2GHZ 6C, 36TB, WINDOWS, REDHAT LINUX SERVER
$679.0
SUN ORACLE X3-2L / X4270 M3 2X 2GHZ 6C, 36TB, WINDOWS, REDHAT LINUX SERVER pictureCYCLADES TS2000 TS-2000 32 PORT RACKMOUNT TERMINAL CONSOLE SERVER LINUX
$180.0
CYCLADES TS2000 TS-2000 32 PORT RACKMOUNT TERMINAL CONSOLE SERVER LINUX pictureHP ProLiant DL380 G7 Rack Server 2x Intel Xeon CPU 24GB RAM 2x600GB HDD Linux
$199.99
HP ProLiant DL380 G7 Rack Server 2x Intel Xeon CPU 24GB RAM 2x600GB HDD Linux pictureGlobalscale Dreamplug Ghz Class Linux Server
$212.18
Globalscale Dreamplug Ghz Class Linux Server picture


Discussions

No Discussions have been posted on this vulnerability.