Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> php file upload


Vulnerability Assessment Details

php file upload

Vulnerability Assessment Summary
Checks for version of PHP

Detailed Explanation for this Vulnerability Assessment

A version of php which is older than 3.0.17
or 4.0.3 is running on this host.

If a php service that permits users to upload files
and then display their content is running on this host,
a possible hacker may be able to read arbitrary files from the server.

Solution : upgrade to php 3.0.17 or 4.0.3, and see also
http://www.php.net/manual/language.variables.predefined.php

Network Security Threat Level: High

Networks Security ID: 1649

Vulnerability Assessment Copyright: This script is Copyright (C) 2000 Renaud Deraison

Cables, Connectors

Rare 8 Buttons ATARI game ION iPad Bluetooth Portable Controller in Original BOX
$29.99
Rare 8 Buttons ATARI game ION iPad Bluetooth Portable Controller in Original BOX pictureAtari Tracker Computer Game Vintage SEALED
$5.0
Atari Tracker Computer Game Vintage SEALED pictureVNTG Protologic & Sound Source, Dr T' Editing Software Atari ST w/ EMU Proteus 1
$224.99
VNTG Protologic & Sound Source, Dr T' Editing Software Atari ST w/ EMU Proteus 1 pictureATARI DUO POWERED JOYSTICK CONTROLLER FOR iPad - ENDLESS FUN
$10.95
ATARI DUO POWERED JOYSTICK CONTROLLER FOR iPad - ENDLESS FUN  picture


Discussions

No Discussions have been posted on this vulnerability.