Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> php IMAP overflow


Vulnerability Assessment Details

php IMAP overflow

Vulnerability Assessment Summary
Checks for version of PHP

Detailed Explanation for this Vulnerability Assessment

A version of php which is older than 4.0.4
is running on this host.

There is a buffer overflow condition in the IMAP
module of this version which may permit a possible hacker
to execute arbitrary commands with the uid of the web
server, if this server is serving a webmail interface.

Solution : Upgrade to PHP 4.0.4

Reference : http://online.securityfocus.com/archive/1/166602

Network Security Threat Level: High

Networks Security ID: 6557

Vulnerability Assessment Copyright: This script is Copyright (C) 2001 Renaud Deraison

Cables, Connectors

Dell R720xd 16-Core Server 2x E5-2660 2.2GHz 32GB 16x 300GB 15K SAS H710 2.5in
$1966.2
Dell R720xd 16-Core Server 2x E5-2660 2.2GHz 32GB 16x 300GB 15K SAS H710 2.5in pictureDell R720xd 16-Core Server 2x E5-2660 2.2GHz 32GB 16x 300GB SAS H710 2.5in
$1467.4
Dell R720xd 16-Core Server 2x E5-2660 2.2GHz 32GB 16x 300GB SAS H710 2.5in pictureDell R710 12-Core Server 2x X5670 2.93GHz 48GB 4x 6TB 6G SAS H700 3.5in Rails
$1492.05
Dell R710 12-Core Server 2x X5670 2.93GHz 48GB 4x 6TB 6G SAS H700 3.5in Rails picture


Discussions

No Discussions have been posted on this vulnerability.