Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Gain root remotely >> ngIRCd Remote Buffer Overflow Vulnerability


Vulnerability Assessment Details

ngIRCd Remote Buffer Overflow Vulnerability

Vulnerability Assessment Summary
checks the version of the remote ircd

Detailed Explanation for this Vulnerability Assessment

The remote host is running a version of the ngIRCd service which may
be vulnerable to a buffer overflow in the way the server handle list
names.

A possible hacker may execute code on the remote host by using a malicious
user information.

Solution : Upgrade to ngIRCd 0.8.2 or newer
Network Security Threat Level: High

Networks Security ID: 12397

Vulnerability Assessment Copyright: This script is Copyright (C) 2005 Tenable Network Security

Cables, Connectors

Rare Vintage Atari 835 Direct Connect Modem Communicator II 400/800 (Turns On)
$399.0
Rare Vintage Atari 835 Direct Connect Modem Communicator II 400/800 (Turns On) pictureCompute’s First, & Third Book of Atari Programming Applications Guides
$65.0
Compute’s First, & Third Book of Atari Programming Applications Guides pictureVintage Atari 400 Personal Computer in box.
$224.99
Vintage Atari 400 Personal Computer in box. pictureVintage Atari 1010 Cassette Tape Drive
$114.99
Vintage Atari 1010 Cassette Tape Drive picture


Discussions

No Discussions have been posted on this vulnerability.