Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Web Servers >> mod_ssl overflow


Vulnerability Assessment Details

mod_ssl overflow

Vulnerability Assessment Summary
Checks for version of mod_ssl

Detailed Explanation for this Vulnerability Assessment

The remote host is using a version of mod_ssl which is
older than 2.8.7.

This version is vulnerable to a buffer overflow which,
albeit difficult to exploit, may permit a possible hacker
to obtain a shell on this host.

*** Some vendors patched older versions of mod_ssl, so this
*** might be a false positive. Check with your vendor to acertain
*** if you have a version of mod_ssl that is patched for this
*** vulnerability


Solution : Upgrade to version 2.8.7 or newer
Network Security Threat Level: High

Networks Security ID: 4189

Vulnerability Assessment Copyright: This script is Copyright (C) 2002 Renaud Deraison

Cables, Connectors

16 GB 4R×R PC3L 8500R DDR3 ECC Reg Server RAM
$19.0
16 GB 4R×R PC3L 8500R DDR3 ECC Reg Server RAM pictureSun Microsystems Netra CT1600 602-2532-02 CompactPCI cPCI Server *
$300.0
Sun Microsystems Netra CT1600 602-2532-02 CompactPCI cPCI Server * pictureHP HSTNS-PL28 643954-201 460W Server Power Supply ^
$35.0
HP HSTNS-PL28 643954-201 460W Server Power Supply ^ pictureDell PowerEdge R320 Server E5-2407 2.40GHz Quad Core H710 NO-RAM
$195.0
Dell PowerEdge R320 Server E5-2407 2.40GHz Quad Core H710 NO-RAM picture


Discussions

No Discussions have been posted on this vulnerability.