Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Web Servers >> mod_ssl off by one


Vulnerability Assessment Details

mod_ssl off by one

Vulnerability Assessment Summary
Checks for version of mod_ssl

Detailed Explanation for this Vulnerability Assessment

The remote host is using a version of mod_ssl which is
older than 2.8.10.

This version is vulnerable to an off by one buffer overflow
which may permit a user with write access to .htaccess files
to execute arbitrary code on the system with permissions
of the web server.

*** Note that several Linux distributions (such as RedHat)
*** patched the old version of this module. Therefore, this
*** might be a false positive. Please check with your vendor
*** to acertain if you really are vulnerable to this flaw

Solution : Upgrade to version 2.8.10 or newer
Network Security Threat Level: High

Networks Security ID: 5084

Vulnerability Assessment Copyright: This script is Copyright (C) 2002 Thomas Reinke

Cables, Connectors

Mini USB 2.0 Micro SD TF T-Flash Memory Card Reader Classical Adapter Blue
$10.0
Mini USB 2.0 Micro SD TF T-Flash Memory Card Reader Classical Adapter Blue  picture8GB DDR3 1600Mhz PC3-12800 204PIN 1.5V CL11 SO-DIMM Laptop Memory=
$25.03
8GB DDR3 1600Mhz PC3-12800 204PIN 1.5V CL11 SO-DIMM Laptop Memory= picture8GB DDR3 1600Mhz PC3-12800 204PIN 1.5V CL11 SO-DIMM Laptop Memory/
$25.03
8GB DDR3 1600Mhz PC3-12800 204PIN 1.5V CL11 SO-DIMM Laptop Memory/ picture8GB DDR3 1600Mhz PC3-12800 204PIN 1.5V CL11 SO-DIMM Laptop Memory*
$25.03
8GB DDR3 1600Mhz PC3-12800 204PIN 1.5V CL11 SO-DIMM Laptop Memory* picture


Discussions

No Discussions have been posted on this vulnerability.