Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Web Servers >> mod_python malformed query


Vulnerability Assessment Details

mod_python malformed query

Vulnerability Assessment Summary
Checks for version of Python

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote web server is prone to a denial of service attack.

Description :

The remote host is using the Apache mod_python module older than 2.7.9
or 3.0.4. These versions may be prone to a denial of service attacks
when handling malformed queries.

See also :

http://www.modpython.org/pipermail/mod_python/2003-November/014533.html

Solution :

Upgrade to mod_python 2.7.9 / 3.0.4 or later.

Network Security Threat Level:

Low / CVSS Base Score : 2.3
(AV:R/AC:L/Au:NR/C:N/I:N/A:P/B:N)

Networks Security ID: 9129

Vulnerability Assessment Copyright: This script is Copyright (C) 2003-2007 Tenable Network Security

Cables, Connectors

Vantec 6-Port SATA II 150 PCI Host Card w/RAID - perfect working condition
$20.0
Vantec 6-Port SATA II 150 PCI Host Card w/RAID - perfect working condition pictureStarTech.com PCISATA4R1 4 Port PCI SATA RAID Controller Adapter Card
$45.0
StarTech.com PCISATA4R1 4 Port PCI SATA RAID Controller Adapter Card pictureWestern Digital My Passport Pro 2TB Thunderbolt Portable RAID Portable Storage
$0.99
Western Digital My Passport Pro 2TB Thunderbolt Portable RAID Portable Storage pictureMicrosoft Windows Server 2016 Essentials Raid 1 Office Home Business 2x2TB G330
$1249.0
Microsoft Windows Server 2016 Essentials Raid 1 Office Home Business 2x2TB  G330 picture


Discussions

No Discussions have been posted on this vulnerability.