Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Gain root remotely >> l2tpd < 0.68 overflow


Vulnerability Assessment Details

l2tpd < 0.68 overflow

Vulnerability Assessment Summary
Acertains the version of the remote l2tpd

Detailed Explanation for this Vulnerability Assessment

The remote host is running a version of l2tpd which is older or
equal to 0.67.

This version is vulnerable to a buffer overflow
which may permit a possible hacker to gain a root shell on this host.

In addition, this program does not initialize its random number generator.
Therefore, a possible hacker may predict some key values and hijack L2TP sessions
established to this host.

Solution : upgrade to l2tpd 0.68 or newer
Network Security Threat Level: High

Networks Security ID: 5451

Vulnerability Assessment Copyright: This script is Copyright (C) 2003 Renaud Deraison

Cables, Connectors

Polycom VVX400 VOIP Phone System --- 3 Phones
$150.0
Polycom VVX400 VOIP Phone System --- 3 Phones pictureLot of 4 Cisco CP-7960G Unified VOIP IP Phones
$79.0
Lot of 4 Cisco CP-7960G Unified VOIP IP Phones  pictureSHORETEL IP485G VOIP Phone 485G Black 630-2101-01 IP Voice Color Display
$299.99
SHORETEL IP485G VOIP Phone 485G Black 630-2101-01 IP Voice Color Display pictureMitel 5320e Black VoIP IP Telephone Backlit Display 50006634 Warranty Quantity
$129.0
Mitel 5320e Black VoIP IP Telephone Backlit Display 50006634 Warranty Quantity picture


Discussions

No Discussions have been posted on this vulnerability.