Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> getID3 < 1.7.8-b1 Multiple Vulnerabilities


Vulnerability Assessment Details

getID3 < 1.7.8-b1 Multiple Vulnerabilities

Vulnerability Assessment Summary
Tries to read a file with getID3's demo.browse.php

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote web server contains a PHP application that is affected by
multiple vulnerabilities.

Description :

getID3, a web-based tool for extracting information from MP3 files, is
installed on the remote web server.

The installation of getID3 includes a set of demo scripts that permit
an unauthenticated remote user to read and delete arbitrary files,
write files with some restrictions, and possibly even permit execution
of arbitrary code, all subject to the rights under which the web
server runs.

Note that getID3 may be installed in support of another application,
such as the Drupal Audio or Mediafield modules.

See also :

http://drupal.org/node/119385
http://www.nessus.org/u?e0625253

Solution :

Either remove the getID3 'demos' directory or upgrade to getID3
version 1.7.8b1 or later.

Network Security Threat Level:

High / CVSS Base Score : 7.0
(AV:R/AC:L/Au:NR/C:P/I:P/A:P/B:N)

Networks Security ID: 22587

Vulnerability Assessment Copyright: This script is Copyright (C) 2007 Tenable Network Security

Cables, Connectors

Dell PowerEdge R620 2x E5-2680v2 2.8GHz 10 Core 32GB 8x 300GB 15K SAS PERC H710
$3790.0
Dell PowerEdge R620 2x E5-2680v2 2.8GHz 10 Core 32GB 8x 300GB 15K SAS PERC H710 pictureDell Poweredge 1800 XEON 2.8GHZ 2GB PS-5651-1 No Drive #
$599.0
Dell Poweredge 1800  XEON 2.8GHZ 2GB PS-5651-1 No Drive # pictureDell 2950 Poweredge 2x Quad Core 3.16Ghz 8GB X5460 QC #
$2499.0
Dell 2950 Poweredge 2x Quad Core 3.16Ghz 8GB X5460 QC # pictureDell PowerEdge R710 2x L5640 2.26GHz 6 Core 96GB 6x 146GB 15K SAS PERC H700
$930.0
Dell PowerEdge R710 2x L5640 2.26GHz 6 Core 96GB 6x 146GB 15K SAS PERC H700 picture


Discussions

No Discussions have been posted on this vulnerability.