Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Gain a shell remotely >> dnsmasq Multiple Remote Vulnerabilities


Vulnerability Assessment Details

dnsmasq Multiple Remote Vulnerabilities

Vulnerability Assessment Summary
Checks the version of dnsmasq

Detailed Explanation for this Vulnerability Assessment

The remote host is running dnsmasq, a DHCP and DNS server.

The remote version of this software is vulnerable to multiple remote
vulnerabilities which may permit a possible hacker to execute arbitrary code on
the remote host or perform a DNS cache poisoning attack.

Solution : Upgrade to dnsmasq 2.21.0 or newer
Network Security Threat Level: High

Networks Security ID: 12897

Vulnerability Assessment Copyright: This script is Copyright (C) 2005 Tenable Network Security

Cables, Connectors

Dell R730xd Server 2x E5-2630 v3 2.4GHz 96GB-8 24x 900GB SAS 2x 600GB HBA330
$4467.45
Dell R730xd Server 2x E5-2630 v3 2.4GHz 96GB-8 24x 900GB SAS 2x 600GB HBA330 pictureDell R730xd 12-Core Server 2x E5-2620 v3 2.4GHz 64GB-8 26x 600GB SAS H730P 2.5in
$3227.7
Dell R730xd 12-Core Server 2x E5-2620 v3 2.4GHz 64GB-8 26x 600GB SAS H730P 2.5in pictureDell R730xd Server 2x E5-2620 v3 2.4GHz 32GB-8 24x 900GB SAS 2x 600GB H730
$4026.65
Dell R730xd Server 2x E5-2620 v3 2.4GHz 32GB-8 24x 900GB SAS 2x 600GB H730 pictureDell R730xd 18-Core Server 2x E5-2630 v3 2.4GHz 96GB-8 26x 300GB 15K SAS H730P
$3452.45
Dell R730xd 18-Core Server 2x E5-2630 v3 2.4GHz 96GB-8 26x 300GB 15K SAS H730P picture


Discussions

No Discussions have been posted on this vulnerability.