Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Gain root remotely >> cfengine format string vulnerability


Vulnerability Assessment Details

cfengine format string vulnerability

Vulnerability Assessment Summary
check for cfengine flaw based on its version

Detailed Explanation for this Vulnerability Assessment

Cfengine is running on this remote host.

Cfengine contains a component, cfd, which serves as a remote-configuration
client to cfengine. This version of cfd contains several flaws in the
way that it calls syslog(). As a result, trusted hosts and valid users
(if access controls are not in place) can cause the vulnerable host to
log malicious data which, when logged, can either crash the server or
execute arbitrary code on the stack. In the latter case, the code would
be executed as the 'root' user.

Solution: Upgrade to 1.6.0a11 or newer

Network Security Threat Level: High

Networks Security ID: 1757

Vulnerability Assessment Copyright: This script is Copyright (C) 2004 David Maciejak

Cables, Connectors

INTEL SERVER BACKPLANE + CAGE + 6 HARD DRIVE TRAY D22808-203
$74.99
INTEL SERVER BACKPLANE + CAGE + 6 HARD DRIVE TRAY D22808-203 pictureMicrosoft Windows Server 2016 Essentials Raid 1 Office Home Business 2x2TB G324
$1249.0
Microsoft Windows Server 2016 Essentials Raid 1 Office Home Business 2x2TB  G324 picture#E2 Dell 0K828C Intel PRO/1000 Quad Port PCIE Server Adapter
$75.0
#E2 Dell 0K828C Intel PRO/1000 Quad Port PCIE Server Adapter picture#E2 Intel Pro/1000 MT Server Adapter PWLA8490MTBLK5
$50.0
#E2 Intel Pro/1000 MT Server Adapter PWLA8490MTBLK5 picture


Discussions

No Discussions have been posted on this vulnerability.