Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> bBlog SQL injection flaw


Vulnerability Assessment Details

bBlog SQL injection flaw

Vulnerability Assessment Summary
Check bBlog version

Detailed Explanation for this Vulnerability Assessment

The remote server runs a version of bBlog, a blogging system written in PHP
and released under the GPL, which is as old as or older than version 0.7.4.

The remote version of this software is affected by a SQL injection
attacks in the script 'rss.php'. This issue is due to a failure
of the application to properly sanitize user-supplied input.

A possible hacker may use these flaws to execute arbitrary PHP code on this
host or to take the control of the remote database.

Solution : Upgrade to version 0.7.4 or newer.
Network Security Threat Level: High

Networks Security ID: 11303

Vulnerability Assessment Copyright: This script is Copyright (C) 2004 David Maciejak

Cables, Connectors

G. SKILL 4 GB DIMM 2666 MHz DDR3 Memory (F3-12800CL9S-4GBXL)
$26.9
G. SKILL 4 GB DIMM 2666 MHz DDR3 Memory (F3-12800CL9S-4GBXL) pictureCrucial 16 GB (2x 8GB) SO-DIMM 1600 MHz PC3-12800 DDR3 Memory (CT102464BF160B)
$89.99
Crucial 16 GB (2x 8GB) SO-DIMM 1600 MHz PC3-12800 DDR3 Memory (CT102464BF160B) pictureLOT 28 Kingston 8GB 240-Pin ECC REG DDR2 667 KVR667D2D4P5/8G 1.8V Server Memory
$4.99
LOT 28 Kingston 8GB 240-Pin ECC REG DDR2 667 KVR667D2D4P5/8G 1.8V Server Memory pictureCorsair 32 GB PC2400 CL11 Vengeance Pro VenPk DDR3 SIMM RAM Memory Module
$250.0
Corsair 32 GB PC2400 CL11 Vengeance Pro VenPk DDR3 SIMM RAM Memory Module picture


Discussions

No Discussions have been posted on this vulnerability.