Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> WordPress Trackback Charset Decoding SQL Injection Vulnerability


Vulnerability Assessment Details

WordPress Trackback Charset Decoding SQL Injection Vulnerability

Vulnerability Assessment Summary
Checks for SQL injection in WordPress

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote web server contains a PHP application that is prone to SQL
injection attacks.

Description :

The version of WordPress on the remote host supports trackbacks in
alternate character sets and decodes them after escaping SQL
parameters. By specifying an alternate character set and encoding
input with that character set while submitting a trackback, an
unauthenticated remote attacker can bypass the application's parameter
sanitation code and manipulate database queries.

Note that exploitation of this issue is only possible when PHP's
mbstring extension is installed, which is apparently the case with the
remote host.

See also :

http://www.hardened-php.net/advisory_022007.141.html
http://archives.neohapsis.com/archives/fulldisclosure/2007-01/0125.html
http://wordpress.org/development/2007/01/wordpress-206/

Solution :

Upgrade to WordPress version 2.0.6 or later.

Network Security Threat Level:

Medium / CVSS Base Score : 5.6
(AV:R/AC:H/Au:NR/C:P/I:P/A:P/B:N)

Networks Security ID: 21896, 21907

Vulnerability Assessment Copyright: This script is Copyright (C) 2007 Tenable Network Security

Cables, Connectors

IBM Delta Power Supply 2000W BladeCenter Servers 24R2711 24R2710 DPS-2000BB
$49.99
IBM Delta Power Supply 2000W BladeCenter Servers 24R2711 24R2710 DPS-2000BB  pictureIBM HS22V BLADECENTER SERVER TWO E5520 2.26GHZ 8GB NO HDD
$529.0
IBM HS22V BLADECENTER SERVER TWO E5520 2.26GHZ 8GB NO HDD pictureIBM HS23 BLADECENTER SERVER TWO E5-2667 2.90GHZ 64GB 2 X 300GB SAS HDD 10K
$3489.0
IBM HS23 BLADECENTER SERVER TWO E5-2667 2.90GHZ 64GB 2 X 300GB SAS HDD 10K pictureIBM HS22V BLADECENTER SERVER TWO E5506 2.13GHZ 64GB NO HDD
$939.0
IBM HS22V BLADECENTER SERVER TWO E5506 2.13GHZ 64GB NO HDD picture


Discussions

No Discussions have been posted on this vulnerability.