Vulnerability Assessment & Network Security Forums

If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.

Home >> Browse Vulnerability Assessment Database >> Gain a shell remotely >> WinProxy HTTP CONNECT Buffer Overflow Vulnerability

Vulnerability Assessment Details

WinProxy HTTP CONNECT Buffer Overflow Vulnerability

Vulnerability Assessment Summary
Checks for WinProxy < 6.1 R1c

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote HTTP proxy is affected by a buffer overflow vulnerability.

Description :

The remote host is running WinProxy, a proxy server for Windows.

The version of WinProxy installed on the remote host reportedly
contains a design issue that may result in a buffer overflow
vulnerability. Using a specially-crafted HTTP CONNECT request, a
remote attacker may be able to leverage this issue to execute arbitary
code on the affected host subject to the rights under which the
service runs.

See also :

Solution :

Upgrade to WinProxy version 6.1 R1c or later as it is rumoured to
address the issue.

Network Security Threat Level:

High / CVSS Base Score : 7.0

Networks Security ID: 22393

Vulnerability Assessment Copyright: This script is Copyright (C) 2007 Tenable Network Security

Cables, Connectors

MacBook Air 11", 1.7GHz Intel Core i7, 8GB Memory, 256GB SSD (Mid 2013)
MacBook Air 11HP Omen 17 17.3" 1080 Gaming Laptop Core i7-7700HQ 8GB 1TB DVDRW GTX1050 W10
HP Omen 17 17.3Open-Box Excellent: Apple - MacBook Air® - 13.3" Display - Intel Core i5 - 8...
Open-Box Excellent: Apple - MacBook Air® - 13.3HP Omen 15.6" Gaming Notebook, Intel Core i7-7700HQ Processor, 8GB Memory
HP Omen 15.6


No Discussions have been posted on this vulnerability.