Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> FTP >> WS FTP server multiple flaws


Vulnerability Assessment Details

WS FTP server multiple flaws

Vulnerability Assessment Summary
Check WS_FTP server version

Detailed Explanation for this Vulnerability Assessment

According to its version number, the remote WS_FTP server is vulnerable to
multiple flaws.

- A buffer overflow, caused by a vulnerability in the ALLO handler, an
attacker can then execute arbitrary code

- A flaw which permit a possible hacker to gain elevated rights (SYSTEM level rights)

- A local or remote attacker, with write rights on a directory can create a
specially crafted file containing a large REST argument and resulting to a denial
of service

** Nessus only checked the version number in the server banner.

Solution : Upgrade to the latest version of this software.
Network Security Threat Level: High

Networks Security ID: 9953

Vulnerability Assessment Copyright: This script is Copyright (C) 2004 David Maciejak

Cables, Connectors

Intel S1200BTL Micro ATX Server Board With I/O plate - Socket H2 LGA 1155
$49.99
Intel S1200BTL Micro ATX Server Board With I/O plate - Socket H2 LGA 1155 pictureHP ProLiant MicroServer Gen8 G1610T 2.3GHz RAM 2GB HDD 4TB (2x2TB)
$249.99
HP ProLiant MicroServer Gen8 G1610T 2.3GHz RAM 2GB HDD 4TB (2x2TB) pictureServer HP ProLiant MicroServer G8 1x G1610T/1P/4GB-U/B120i/SATA/(not Hot Plug
$321.72
Server HP ProLiant MicroServer G8 1x G1610T/1P/4GB-U/B120i/SATA/(not Hot Plug picturesuper micro computer 7044h-82
$0.01
super micro computer 7044h-82 picture


Discussions

No Discussions have been posted on this vulnerability.