Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> ViRobot Linux Server Remote Buffer Overflow Vulnerability


Vulnerability Assessment Details

ViRobot Linux Server Remote Buffer Overflow Vulnerability

Vulnerability Assessment Summary
Checks for remote buffer overflow vulnerability in ViRobot Linux Server

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote server is prone to a remote buffer overflow attack.

Description :

The remote host is running ViRobot Linux Server, a commercial anti-
virus product for Linux.

According to its banner, the installed version of ViRobot Linux Server
suffers from a remote buffer overflow vulnerability in its web-based
management interface. By passing specially-crafted data through the
'ViRobot_ID' and 'ViRobot_PASS' cookies when calling the 'addschup'
CGI script, an unauthenticated attacker may be able to write arbitrary
data to root's crontab entry, thus giving him complete control over
the affected host.

See also :

http://www.digitalmunition.com/DMA%5B2005-0614a%5D.txt
http://archives.neohapsis.com/archives/fulldisclosure/2005-06/0188.html
http://www.globalhauri.com/html/download/down_unixpatch.html

Solution :

Unknown at this time.

Network Security Threat Level:

Critical / CVSS Base Score : 10
(AV:R/AC:L/Au:NR/C:C/A:C/I:C/B:N)

Networks Security ID: 13964

Vulnerability Assessment Copyright: This script is Copyright (C) 2005-2006 Tenable Network Security

Cables, Connectors

Intel PCIe SSD AIC RAID Controller Card G97168-252
$49.0
Intel PCIe SSD AIC RAID Controller Card G97168-252 pictureLot of 2 Dell XM771 PowerEdge PERC 5/i PCI Express x8 SAS RAID Controller Card
$24.68
Lot of 2 Dell XM771 PowerEdge PERC 5/i PCI Express x8 SAS RAID Controller Card pictureDell YK838 PowerEdge PERC 6/iR PCI Express x8 RAID Card
$8.99
Dell YK838 PowerEdge PERC 6/iR PCI Express x8 RAID Card pictureSonnet Storage controller M.2 NVMe Card RAID 0 5 FUS-SSD-4X4-E3
$1.0
Sonnet Storage controller M.2 NVMe Card RAID 0 5 FUS-SSD-4X4-E3 picture


Discussions

No Discussions have been posted on this vulnerability.