Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Ubuntu Local Security Checks >> USN93-1 : squid vulnerability


Vulnerability Assessment Details

USN93-1 : squid vulnerability

Vulnerability Assessment Summary
squid vulnerability

Detailed Explanation for this Vulnerability Assessment

Summary :

These remote packages are missing security patches :
- squid
- squid-cgi
- squid-common
- squidclient


Description :

A race condition was discovered in the handling of "Set-Cookie"
headers. If the obsolete Netscape recommendation was used for handling
cookies in the cache, it was possible for a possible hacker to steal the
cookies of other users.

Solution :

Upgrade to :
- squid-2.5.5-6ubuntu0.6 (Ubuntu 4.10)
- squid-cgi-2.5.5-6ubuntu0.6 (Ubuntu 4.10)
- squid-common-2.5.5-6ubuntu0.6 (Ubuntu 4.10)
- squidclient-2.5.5-6ubuntu0.6 (Ubuntu 4.10)



Network Security Threat Level: High


Networks Security ID:

Vulnerability Assessment Copyright: Ubuntu Security Notice (C) 2005 Canonical, Inc. / NASL script (C) 2005 Michel Arboi

Cables, Connectors

Lot of 7 LSI SAS3081E-R 8 Port Internal SAS/SATA 3GB/s RAID Controller Card
$39.99
Lot of 7 LSI SAS3081E-R 8 Port Internal SAS/SATA 3GB/s RAID Controller Card pictureBroadcom MegaRAID 9460-16i RAID controller card 4GB cache w/battery + cable
$789.0
Broadcom MegaRAID 9460-16i RAID controller card 4GB cache w/battery + cable pictureSIIG Serial ATA 4-Channel RAID
$53.83
SIIG Serial ATA 4-Channel RAID pictureDELL H200 DUAL PORT 6GB PCIE SAS RAID CONTROLLER D P/N 3J8FW
$29.95
DELL H200 DUAL PORT 6GB PCIE SAS RAID CONTROLLER D P/N 3J8FW picture


Discussions

No Discussions have been posted on this vulnerability.