Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Ubuntu Local Security Checks >> USN52-1 : vim vulnerability


Vulnerability Assessment Details

USN52-1 : vim vulnerability

Vulnerability Assessment Summary
vim vulnerability

Detailed Explanation for this Vulnerability Assessment

Summary :

These remote packages are missing security patches :
- kvim
- vim
- vim-common
- vim-doc
- vim-gnome
- vim-gtk
- vim-lesstif
- vim-perl
- vim-python
- vim-tcl


Description :

Ciaran McCreesh found several vulnerabilities related to the use of
options in Vim modeline commands, such as 'termcap', 'printdevice',
'titleold', 'filetype', 'syntax', 'backupext', 'keymap', 'patchmode',
and 'langmenu'.

If a possible hacker tricked an user to open a file with a specially crafted
modeline, he could exploit this to execute arbitrary commands with the
user's rights.

Solution :

Upgrade to :
- kvim-6.3-025+1ubuntu2.1 (Ubuntu 4.10)
- vim-6.3-025+1ubuntu2.1 (Ubuntu 4.10)
- vim-common-6.3-025+1ubuntu2.1 (Ubuntu 4.10)
- vim-doc-6.3-025+1ubuntu2.1 (Ubuntu 4.10)
- vim-gnome-6.3-025+1ubuntu2.1 (Ubuntu 4.10)
- vim-gtk-6.3-025+1ubuntu2.1 (Ubuntu 4.10)
- vim-lesstif-6.3-025+1ubuntu2.1 (Ubuntu 4.10)
- vim-perl-6.3-025+1ubuntu2.1 (Ubuntu 4.10)
- vim-python-6.3-025+1ubuntu2.1 (Ubuntu 4.10)
- vim-tcl-6.3-025+1ubuntu2.1 (Ubuntu 4.10)



Network Security Threat Level: High


Networks Security ID:

Vulnerability Assessment Copyright: Ubuntu Security Notice (C) 2005 Canonical, Inc. / NASL script (C) 2005 Michel Arboi

Cables, Connectors

Fortinet Fortigate FG-60c Firewall Appliance PARTS/REPAIR
$35.0
Fortinet Fortigate FG-60c Firewall Appliance PARTS/REPAIR pictureBARRACUDA BNGF10A FIREWALL USED Working No Licence info FW-6430f-BA1
$40.0
BARRACUDA BNGF10A FIREWALL USED Working No Licence info FW-6430f-BA1 pictureNetgear FVS318 ProSafe VPN Firewall 8 with 8-Port 10/100 Switch
$17.0
Netgear FVS318 ProSafe VPN Firewall 8 with 8-Port 10/100 Switch picture 300Mbps Wireless-N 4-Port Router Firewall & Cloud
$23.24
 300Mbps Wireless-N 4-Port Router Firewall & Cloud picture


Discussions

No Discussions have been posted on this vulnerability.