Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Ubuntu Local Security Checks >> USN5-1 : gettext vulnerabilities


Vulnerability Assessment Details

USN5-1 : gettext vulnerabilities

Vulnerability Assessment Summary
gettext vulnerabilities

Detailed Explanation for this Vulnerability Assessment

Summary :

These remote packages are missing security patches :
- gettext
- gettext-base
- gettext-doc
- gettext-el


Description :

Recently, Trustix Secure Linux discovered some vulnerabilities in the
gettext package. The programs "autopoint" and "gettextize" created
temporary files in an insecure way, which permited a symlink attack to
create or overwrite arbitrary files with the rights of the user
invoking the program.

Solution :

Upgrade to :
- gettext-0.14.1-2ubuntu0.1 (Ubuntu 4.10)
- gettext-base-0.14.1-2ubuntu0.1 (Ubuntu 4.10)
- gettext-doc-0.14.1-2ubuntu0.1 (Ubuntu 4.10)
- gettext-el-0.14.1-2ubuntu0.1 (Ubuntu 4.10)



Network Security Threat Level: High


Networks Security ID:

Vulnerability Assessment Copyright: Ubuntu Security Notice (C) 2005 Canonical, Inc. / NASL script (C) 2005 Michel Arboi

Cables, Connectors

Intel Server Motherboard D86139-302 Socket 775 motherboard S3200SH
$102.85
Intel Server Motherboard D86139-302 Socket 775 motherboard S3200SH pictureLenovo ThinkServer TS140 Tower Server System #70A40083UX
$259.95
Lenovo ThinkServer TS140 Tower Server System #70A40083UX pictureDELL POWEREDGE SC420 SERVER LOCKING FRONT BEZEL W/ KEY 0FXV9H
$24.99
DELL POWEREDGE SC420 SERVER LOCKING FRONT BEZEL W/ KEY 0FXV9H pictureDell PowerEdge R720 Server Internal Case Cooling Fan WCRWR 0WCRWR 9GA0612P1K641
$45.4
Dell PowerEdge R720 Server Internal Case Cooling Fan WCRWR 0WCRWR 9GA0612P1K641 picture


Discussions

No Discussions have been posted on this vulnerability.