Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Ubuntu Local Security Checks >> USN45-1 : nasm vulnerability


Vulnerability Assessment Details

USN45-1 : nasm vulnerability

Vulnerability Assessment Summary
nasm vulnerability

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote package "nasm" is missing a security patch.

Description :

Jonathan Rockway discovered a locally exploitable buffer overflow in
the error() function of nasm. If a possible hacker tricked a user into
assembling a malicious source file, they could exploit this to execute
arbitrary code with the rights of the user that runs nasm.

Solution :

Upgrade to :
- nasm-0.98.38-1ubuntu0.1 (Ubuntu 4.10)



Network Security Threat Level: High


Networks Security ID:

Vulnerability Assessment Copyright: Ubuntu Security Notice (C) 2005 Canonical, Inc. / NASL script (C) 2005 Michel Arboi

Cables, Connectors

Mini Vacuum Air Extracting USB Cooling Pads Cooler Fan For Notebook Laptop Y0E4
$10.59
Mini Vacuum Air Extracting USB Cooling Pads Cooler Fan For Notebook Laptop Y0E4 pictureK27 USB External Vacuum Laptop Cooling Cooler Fan Radiator For PC Notebook O6A3
$9.29
K27 USB External Vacuum Laptop Cooling Cooler Fan Radiator For PC Notebook O6A3 pictureRubbermaid System Sweeper PC Vacuum #440 110-Volt in working condition
$5.1
Rubbermaid System Sweeper PC Vacuum #440 110-Volt in working condition pictureCOOLCOLD Vacuum K27 Laptop Cooler USB Air Extracting Cooling Fan Radiator V5Y7
$8.99
COOLCOLD Vacuum K27 Laptop Cooler USB Air Extracting Cooling Fan Radiator V5Y7 picture


Discussions

No Discussions have been posted on this vulnerability.