Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Ubuntu Local Security Checks >> USN39-1 : linux-source-2.6.8.1 vulnerability


Vulnerability Assessment Details

USN39-1 : linux-source-2.6.8.1 vulnerability

Vulnerability Assessment Summary
linux-source-2.6.8.1 vulnerability

Detailed Explanation for this Vulnerability Assessment

Summary :

These remote packages are missing security patches :
- linux-doc-2.6.8.1
- linux-headers-2.6.8.1-4
- linux-headers-2.6.8.1-4-386
- linux-headers-2.6.8.1-4-686
- linux-headers-2.6.8.1-4-686-smp
- linux-headers-2.6.8.1-4-amd64-generic
- linux-headers-2.6.8.1-4-amd64-k8
- linux-headers-2.6.8.1-4-amd64-k8-smp
- linux-headers-2.6.8.1-4-amd64-xeon
- linux-headers-2.6.8.1-4-k7
- linux-headers-2.6.8.1-4-k7-smp
- linux-headers-2.6.8.1-4-power3
- linux-headers-2.6.8.1-4-power3-smp
- linux-headers-2.6.8.
[...]

Description :

USN-30-1 fixed several flaws in the Linux ELF binary loader's handling
of setuid binaries. Unfortunately it was found that these patches were
not sufficient to prevent all possible attacks on 64-bit platforms, so
previous amd64 kernel images were still vulnerable to root privilege
escalation if setuid binaries were run under certain conditions.

This issue does not affect the i386 and powerpc platforms.

Solution :

Upgrade to :
- linux-doc-2.6.8.1-2.6.8.1-16.4 (Ubuntu 4.10)
- linux-headers-2.6.8.1-4-2.6.8.1-16.4 (Ubuntu 4.10)
- linux-headers-2.6.8.1-4-386-2.6.8.1-16.4 (Ubuntu 4.10)
- linux-headers-2.6.8.1-4-686-2.6.8.1-16.4 (Ubuntu 4.10)
- linux-headers-2.6.8.1-4-686-smp-2.6.8.1-16.4 (Ubuntu 4.10)
- linux-headers-2.6.8.1-4-amd64-generic-2.6.8.1-16.4 (Ubuntu 4.10)
- linux-headers-2.6.8.1-4-amd64-k8-2.6.8.1-16.4 (Ubuntu 4.10)
- linux-headers-2.6.8.1-4-amd64-k8-smp-2.6.8.1-16.4 (Ubuntu 4.10)
- linux-headers-2.6.8.1-4-a
[...]


Network Security Threat Level: High


Networks Security ID:

Vulnerability Assessment Copyright: Ubuntu Security Notice (C) 2005 Canonical, Inc. / NASL script (C) 2005 Michel Arboi

Cables, Connectors

HP Procurve al Switch Module Slot Cover Back Panel J9145A J9146A J9147A J9148A
$19.99
HP Procurve al Switch Module Slot Cover Back Panel J9145A J9146A J9147A J9148A pictureCisco PIDVID CTS-CTRL-DV10 V01 (74-100411-02) (50C)
$295.0
Cisco PIDVID CTS-CTRL-DV10 V01 (74-100411-02) (50C) pictureARUBA HP PROCURVE 2920-48G J9728A 48-PORT GIGABIT ETHERNET 4-SFP NETWORK SWITCH
$299.99
ARUBA HP PROCURVE 2920-48G J9728A 48-PORT GIGABIT ETHERNET 4-SFP NETWORK SWITCH pictureHP ARUBA PROCURVE 2920-48G 48-PORT GIGABIT ETHERNET 4-SFP NETWORK SWITCH J9728A
$299.99
HP ARUBA PROCURVE 2920-48G 48-PORT GIGABIT ETHERNET 4-SFP NETWORK SWITCH J9728A picture


Discussions

No Discussions have been posted on this vulnerability.