Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Ubuntu Local Security Checks >> USN280-1 : xorg vulnerability


Vulnerability Assessment Details

USN280-1 : xorg vulnerability

Vulnerability Assessment Summary
xorg vulnerability

Detailed Explanation for this Vulnerability Assessment

Summary :

These remote packages are missing security patches :
- lbxproxy
- libdmx-dev
- libdmx1
- libdmx1-dbg
- libdps-dev
- libdps1
- libdps1-dbg
- libfs-dev
- libfs6
- libfs6-dbg
- libice-dev
- libice6
- libice6-dbg
- libsm-dev
- libsm6
- libsm6-dbg
- libx11-6
- libx11-6-dbg
- libx11-dev
- libxau-dev
- libxau6
- libxau6-dbg
- libxaw6
- libxaw6-dbg
- libxaw6-dev
- libxaw7
- libxaw7-dbg
- libxaw7-dev
- libxaw8
- libxaw8-dbg
- libxaw8-dev
- libxcomposite-dev
- libxcomposite1
- libxco
[...]

Description :

The Render extension of the X.org server incorrectly calculated the
size of a memory buffer, which led to a buffer overflow. A local
attacker could exploit this to crash the X server or even execute
arbitrary code with root rights.

Solution :

Upgrade to :
- lbxproxy-6.8.2-10.2 (Ubuntu 5.04)
- libdmx-dev-6.8.2-10.2 (Ubuntu 5.04)
- libdmx1-6.8.2-10.2 (Ubuntu 5.04)
- libdmx1-dbg-6.8.2-10.2 (Ubuntu 5.04)
- libdps-dev-6.8.2-10.2 (Ubuntu 5.04)
- libdps1-6.8.2-10.2 (Ubuntu 5.04)
- libdps1-dbg-6.8.2-10.2 (Ubuntu 5.04)
- libfs-dev-6.8.2-10.2 (Ubuntu 5.04)
- libfs6-6.8.2-10.2 (Ubuntu 5.04)
- libfs6-dbg-6.8.2-10.2 (Ubuntu 5.04)
- libice-dev-6.8.2-10.2 (Ubuntu 5.04)
- libice6-6.8.2-10.2 (Ubuntu 5.04)
- libice6-dbg-6.8.2-10.2 (Ubuntu 5.04)
- libsm-dev-6.8.
[...]


Network Security Threat Level: High


Networks Security ID:

Vulnerability Assessment Copyright: Ubuntu Security Notice (C) 2005 Canonical, Inc. / NASL script (C) 2005 Michel Arboi

Cables, Connectors

DELL POWEREDGE R630 10 BAY TWO E5-2623V3 3GHZ 96GB 9 X 1.2TB 10K 12G H730
$4689.0
DELL POWEREDGE R630 10 BAY TWO E5-2623V3 3GHZ 96GB 9 X 1.2TB 10K 12G H730 pictureDELL POWEREDGE R720 8B 2.5 SERVER E5-2630LV2 2.40GHZ 32GB 8 X 800GB SSD H710P
$4739.0
DELL POWEREDGE R720 8B 2.5 SERVER E5-2630LV2 2.40GHZ 32GB 8 X 800GB SSD H710P pictureDELL POWEREDGE R630 10 BAY TWO E5-2667V3 3.2GHZ 96GB 6 X 600GB 15K 12G H330
$4769.0
DELL POWEREDGE R630 10 BAY TWO E5-2667V3 3.2GHZ 96GB 6 X 600GB 15K 12G H330 picture


Discussions

No Discussions have been posted on this vulnerability.