Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Ubuntu Local Security Checks >> USN269-1 : xscreensaver vulnerability


Vulnerability Assessment Details

USN269-1 : xscreensaver vulnerability

Vulnerability Assessment Summary
xscreensaver vulnerability

Detailed Explanation for this Vulnerability Assessment

Summary :

These remote packages are missing security patches :
- xscreensaver
- xscreensaver-gl
- xscreensaver-gnome
- xscreensaver-nognome


Description :

In some cases, xscreensaver did not properly grab the keyboard when
reading the password for unlocking the screen, so that the password
was typed into the currently active application window.

The only known vulnerable case was when xscreensaver activated while
an rdesktop session was currently active.

Solution :

Upgrade to :
- xscreensaver-4.16-1ubuntu11.1 (Ubuntu 5.04)
- xscreensaver-gl-4.16-1ubuntu11.1 (Ubuntu 5.04)
- xscreensaver-gnome-4.16-1ubuntu11.1 (Ubuntu 5.04)
- xscreensaver-nognome-4.16-1ubuntu11.1 (Ubuntu 5.04)



Network Security Threat Level: High


Networks Security ID:

Vulnerability Assessment Copyright: Ubuntu Security Notice (C) 2005 Canonical, Inc. / NASL script (C) 2005 Michel Arboi

Cables, Connectors

New Sandisk Cruzer Dial 64GB USB 2.0 Flash Drive
$14.95
New Sandisk Cruzer Dial 64GB USB 2.0 Flash Drive picture256GB Flash Drive *Used*
$24.0
256GB Flash Drive *Used* pictureAPPLE MacBook Air 11.6" In 128GB Flash Storage Intel Core I5 Laptop/Notebook
$268.99
APPLE MacBook Air 11.61PC Hot High Speed Mini USB 2.0 Micro SD TF T-Flash Memory Card Reader Adapter
$0.01
1PC Hot High Speed Mini USB 2.0 Micro SD TF T-Flash Memory Card Reader Adapter picture


Discussions

No Discussions have been posted on this vulnerability.