Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Ubuntu Local Security Checks >> USN261-1 : php4, php5 vulnerabilities


Vulnerability Assessment Details

USN261-1 : php4, php5 vulnerabilities

Vulnerability Assessment Summary
php4, php5 vulnerabilities

Detailed Explanation for this Vulnerability Assessment

Summary :

These remote packages are missing security patches :
- libapache2-mod-php4
- libapache2-mod-php5
- php-pear
- php4
- php4-cgi
- php4-cli
- php4-common
- php4-curl
- php4-dev
- php4-domxml
- php4-gd
- php4-ldap
- php4-mcal
- php4-mhash
- php4-mysql
- php4-odbc
- php4-pear
- php4-recode
- php4-snmp
- php4-sybase
- php4-xslt
- php5
- php5-cgi
- php5-cli
- php5-common
- php5-curl
- php5-dev
- php5-gd
- php5-ldap
- php5-mhash
- php5-mysql
- php5-odbc
- php5-pgsql
- php5-recode

[...]

Description :

Stefan Esser discovered that the 'session' module did not sufficiently
verify the validity of the user-supplied session ID. A remote attacker
could exploit this to insert arbitrary HTTP headers into the response
sent by the PHP application, which could lead to HTTP Response
Splitting (forging of arbitrary responses on behalf the PHP
application) and Cross Site Scripting (XSS) (execution of arbitrary
web script code in the client's browser) attacks. (CVE-2006-0207)

PHP applications were also vulnerable to several Cross Site Scripting
(XSS) flaws if the options 'display_errors' and 'html_errors' were
enabled. Please note that enabling 'html_errors' is not recommended
for production systems. (CVE-2006-0208)

Solution :

Upgrade to :
- libapache2-mod-php4-4.3.10-10ubuntu4.4 (Ubuntu 5.04)
- libapache2-mod-php5-5.0.5-2ubuntu1.2 (Ubuntu 5.10)
- php-pear-5.0.5-2ubuntu1.2 (Ubuntu 5.10)
- php4-4.3.10-10ubuntu4.4 (Ubuntu 5.04)
- php4-cgi-4.3.10-10ubuntu4.4 (Ubuntu 5.04)
- php4-cli-4.3.10-10ubuntu4.4 (Ubuntu 5.04)
- php4-common-4.3.10-10ubuntu4.4 (Ubuntu 5.04)
- php4-curl-4.3.8-3ubuntu7.15 (Ubuntu 4.10)
- php4-dev-4.3.10-10ubuntu4.4 (Ubuntu 5.04)
- php4-domxml-4.3.8-3ubuntu7.15 (Ubuntu 4.10)
- php4-gd-4.3.8-3ubuntu7.15 (Ubuntu 4.
[...]


Network Security Threat Level: High


Networks Security ID:

Vulnerability Assessment Copyright: Ubuntu Security Notice (C) 2005 Canonical, Inc. / NASL script (C) 2005 Michel Arboi

Cables, Connectors

Samsung EVO850 250GB SSD (MZ-7LN250)
$50.0
Samsung EVO850 250GB SSD (MZ-7LN250) picturewd 4tb external hard drive
$75.0
wd 4tb external hard drive pictureSeagate 3TB Internal Hard Drive ST3000DM001 OEM 7200 RPM
$67.89
Seagate 3TB  Internal Hard Drive ST3000DM001 OEM 7200 RPM picture2.5" hard drive 40GB IDE Hitachi
$9.99
2.5


Discussions

No Discussions have been posted on this vulnerability.